<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="g-yqrtitxECbo8En7BB1icfKvHnInKgzjakSBPhxvOPbekzc5eRWWKU8-D-vEHoNHMAN9GSh8XAQ2GRXm-zXtQ" />
<meta charset="utf-8">
<title>It Feels Like a Horror Movie: On Trey Edward Shults' Krisha | Far Flungers | Roger Ebert</title>
<meta content="It Feels Like a Horror Movie: On Trey Edward Shults&#39; Krisha | Far Flungers | Roger Ebert" itemprop="name">
<meta content="An FFC looks at Krisha, which will play at this year&#39;s Ebertfest next week. " itemprop="description">
<meta content="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha/homepage_krisha-4.jpg" itemprop="image">
<meta content="An FFC looks at Krisha, which will play at this year&#39;s Ebertfest next week. " name="description">
<meta content="Seongyong Cho" name="author">
<meta content="&amp;copy; Copyright 2022" name="copyright">
<meta content="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha/homepage_krisha-4.jpg" name="image">
<meta content="It Feels Like a Horror Movie: On Trey Edward Shults&#39; Krisha | Far Flungers | Roger Ebert" name="DC.title">
<meta content="An FFC looks at Krisha, which will play at this year&#39;s Ebertfest next week. " name="DC.description">
<meta content="Seongyong Cho" name="DC.creator">
<meta content="article" name="og:type">
<meta content="It Feels Like a Horror Movie: On Trey Edward Shults&#39; Krisha | Far Flungers | Roger Ebert" name="og:title">
<meta content="An FFC looks at Krisha, which will play at this year&#39;s Ebertfest next week. " name="og:description">
<meta content="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha/homepage_krisha-4.jpg" name="og:image">
<meta content="https://www.rogerebert.com/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha" name="og:url">
<meta content="https://www.rogerebert.com/" name="og:site_name">
<meta content="en_US" name="og:locale">
<meta content="162770253735982" name="fb:admins">
<meta content="summary_large_image" name="twitter:card">
<meta content="It Feels Like a Horror Movie: On Trey Edward Shults&#39; Krisha | Far Flungers | Roger Ebert" name="twitter:title">
<meta content="An FFC looks at Krisha, which will play at this year&#39;s Ebertfest next week. " name="twitter:description">
<meta content="@ebertchicago" name="twitter:site">
<meta content="@ebertchicago" name="twitter:creator">
<meta content="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha/homepage_krisha-4.jpg" name="twitter:image:src">
<meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible">
<meta content="false" http-equiv="imagetoolbar">
<meta content="on" http-equiv="cleartype">
<meta content="True" name="HandheldFriendly">
<meta content="320" name="MobileOptimized">
<meta content="width=device-width, initial-scale=1.0" name="viewport">
<meta content="SXd00dFh4iZgM0Zq0oUlLDysCVVYjStrX255Gs8EpqM" name="google-site-verification">

<link rel="canonical" href="https://www.rogerebert.com/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha" />


<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script src="https://cdn.adligature.com/ebert/prod/rules.js"></script>

<script language="javascript" type="text/javascript">
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>

<link rel="stylesheet" media="screen" href="/packs/css/application-bb433f68.css" />
<link rel="stylesheet" media="screen" href="https://use.typekit.net/fdo4xio.css" />
<script>
var b = document.documentElement;
b.setAttribute('data-useragent',  navigator.userAgent);
b.setAttribute('data-platform', navigator.platform );
</script>
<link href="/assets/fav/apple-touch-icon-57x57-9e12b6d6d15bfb3e86f09c3fc7d58a6f8a2d808cb856df9c1ada23480cda1dae.png" rel="apple-touch-icon-precomposed" sizes="57x57">
<link href="/assets/fav/apple-touch-icon-114x114-e2a237906826ea251e9d0415208742175a9bb609b16c9ec3d0ca754d12cc87fd.png" rel="apple-touch-icon-precomposed" sizes="114x114">
<link href="/assets/fav/apple-touch-icon-72x72-8b1e1fdaa9cb093aeee4e960c5e60769bb38daa53bff520fd6460b93c8b2a165.png" rel="apple-touch-icon-precomposed" sizes="72x72">
<link href="/assets/fav/apple-touch-icon-144x144-cc9ce51a6832ac55452777045f308380154e81b7f3095b0a2280349920c1deab.png" rel="apple-touch-icon-precomposed" sizes="144x144">
<link href="/assets/fav/apple-touch-icon-60x60-f8a0915e5ab089c1a58106994ece80f176411e9a71e9343b954deb3e6ac65208.png" rel="apple-touch-icon-precomposed" sizes="60x60">
<link href="/assets/fav/apple-touch-icon-120x120-99dad83377eedf9c4f17d3c96777ac68ae8dd49cc42ec8023d6404a19b47d92e.png" rel="apple-touch-icon-precomposed" sizes="120x120">
<link href="/assets/fav/apple-touch-icon-76x76-52591ecca8b31243695a12528a5fd08d4b72628f73a19d0d1e3379a9a7350d30.png" rel="apple-touch-icon-precomposed" sizes="76x76">
<link href="/assets/fav/apple-touch-icon-152x152-9b3e90875f572a4c7c718d8d6271ef8849137c2e5d99a637bac9608fa1e0190c.png" rel="apple-touch-icon-precomposed" sizes="152x152">
<link href="/assets/fav/favicon-196x196-e11c28ccdbdd131ae271453581a65c68c19affb80e694897e34c86c1d663f9ab.png" rel="icon" sizes="196x196" type="image/png">
<link href="/assets/fav/favicon-96x96-788de9aca64fe700f535a7d4c0b39100f9ab9961e0c4d22ee1791187f9aeb549.png" rel="icon" sizes="96x96" type="image/png">
<link href="/assets/fav/favicon-32x32-2d7cd969aa6531528c51bd0d67b7eb3fcb901d0f01e2161f929a0e38d44f99f6.png" rel="icon" sizes="32x32" type="image/png">
<link href="/assets/fav/favicon-16x16-f4fc10f7dc59f5e6fa65eef34a365222b856b43e74eb06e6986611ea439a5bfe.png" rel="icon" sizes="16x16" type="image/png">
<link href="/assets/fav/favicon-128-7964630265afe1c9f51d2c5c95e61695007fb6e00be06bd1ff3d2eaf738ed88c.png" rel="icon" sizes="128x128" type="image/png">
<meta content="Roger Ebert" name="application-name">
<meta content="#FFFFFF" name="msapplication-TileColor">
<meta content="/assets/fav/mstile-144x144-cc9ce51a6832ac55452777045f308380154e81b7f3095b0a2280349920c1deab.png" name="msapplication-TileImage">
<meta content="/assets/fav/mstile-70x70-7964630265afe1c9f51d2c5c95e61695007fb6e00be06bd1ff3d2eaf738ed88c.png" name="msapplication-square70x70logo">
<meta content="/assets/fav/mstile-150x150-d6b67c1aabdd5ef5edfaaaf714c0359f488576e42aa76016f642899155b12e8b.png" name="msapplication-square150x150logo">
<meta content="/assets/fav/mstile-310x150-95bfd05d317f335e1f27c433a39374d2b6eff919834a95212ddf57aab53083ab.png" name="msapplication-wide310x150logo">
<meta content="/assets/fav/mstile-310x310-c26f19826551dbc73a53e1959f4b9e33bb3a3af70a8f5040d97d8050f6b6014b.png" name="msapplication-square310x310logo">

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6324575" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6324575&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->
</head>
<body>
<header class="north">
<div class="container is-fullhd">
<div class="branding">
<a href="/"><img alt="Roger Ebert Home" src="/assets/logo/rogerebert-fea9f2c27bcb671adfb84f275757a289ffd85f5370aeffb12f481bf5a3241543.svg" /></a>
<form class="header-site-search" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" /><div class="field has-addons">
<div class="control">
<input type="text" name="q" id="q" class="input search-input" placeholder="Search movies and more..." />
</div>
<div class="control">
<input class="search-button" title="Search" type="submit" value="">
</div>
</div>
</form></div>
<div aria-label="navigation" class="navbar is-transparent" role="navigation">
<div class="navbar-brand">
<a class="navbar-item" href="/"><img width="262" alt="Roger Ebert Home" class="navbar-logo" src="/assets/logo/rogerebert-fea9f2c27bcb671adfb84f275757a289ffd85f5370aeffb12f481bf5a3241543.svg" /></a>
<a aria-expanded="false" aria-label="menu" class="navbar-burger burger" data-target="mainNavigation" role="button">
<span aria-hidden="true"></span>
<span aria-hidden="true"></span>
<span aria-hidden="true"></span>
</a>
</div>
<div class="navbar-menu" id="mainNavigation">
<div class="navbar-start">
<h4>
<a title="Great Movies" class="navbar-item" href="/great-movies"><img alt="Great Movies" title="Great Movies" class="review-stack--icon-gm navbar-icon" src="/assets/icons/great-movies-small-9dfdde4ea69b270580c266f0e23c6a65b4ede6004cd164c31560e7c1860677f7.svg" />
Great Movies
</a></h4>
<h4>
<a title="Collections" class="navbar-item" href="https://www.rogerebert.com/collections">
Collections
</a></h4>
<h4>
<a title="TV/Streaming" class="navbar-item" href="/streaming">
TV/Streaming
</a></h4>
<h4>
<a title="Interviews" class="navbar-item" href="/interviews">
Interviews
</a></h4>
<h4>
<a title="Movie Reviews" class="navbar-item" href="/reviews">
Movie Reviews
</a></h4>
<h4>
<a title="Chaz&#39;s Journal" class="navbar-item" href="/chazs-blog">
Chaz&#39;s Journal
</a></h4>
<h4>
<a title="Contributors" class="navbar-item" href="https://www.rogerebert.com/contributors">
Contributors
</a></h4>
</div>
<div class="navbar-end">
<div class="navbar-item">
<form class="header-site-search--mobile" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" /><div class="field has-addons">
<div class="control">
<input type="text" name="q" id="q" class="input search-input" placeholder="Search movies and more..." />
</div>
<div class="control">
<input class="search-button" title="Search" type="submit" value="">
</div>
</div>
</form></div>
</div>
</div>
</div>
<section class="page-content--ad-block column is-12 is-paddingless">
<div class="advertisement">
<div class="advertisement--container">
<div class="AdvallyTag" data-autosize="" data-slot="/29848019/ROS_TOP_LEADERBOARD" id="ROS_TOP_LEADERBOARD"></div>
</div>
</div>
</section>

</div>
</header>

<div class="page-content container is-fullhd">
<div class="columns is-centered is-mobile is-spaced--medium">
<div class="column is-6-tablet is-12-mobile">
<div class="page-content--block">
<a class="page-content--category" href="/far-flung-correspondents">Far Flungers</a>

<h1 class="page-content--title"><div class="columns is-spaced--medium">
<div class="column">
It Feels Like a Horror Movie: On Trey Edward Shults' Krisha
</div>
</div>
</h1>
<div class="page-content--byline-share">
<div class="page-content--byline-share--byline">
<span class="byline">
<a href="/contributors/seongyong-cho">Seongyong Cho</a>
</span>
<time class="time">April 11, 2022</time>

</div>
<div class="page-content--byline-share--share">
<section class="page-content--share">
<div class="page-content--share--facebook">
<iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.rogerebert.com%2Ffar-flung-correspondents%2Fit-feels-like-a-horror-movie-on-trey-edward-shults-krisha&amp;layout=button_count&amp;show_faces=false&amp;width=90&amp;action=like&amp;font=arial&amp;colorscheme=light&amp;height=80" scrolling="no" frameborder="0" allowtransparency="true" id="facebook_like" style="height: 20px; width: 90px; display: inline-block;"></iframe>
</div>
<div class="page-content--share--twitter">
<a href="https://twitter.com/share" class="twitter-share-button" data-related="ebertchicago" rel="nofollow">Tweet</a><script type="text/javascript">!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
</section>

</div>
</div>


</div>
</div>
</div>
<div class="columns is-centered is-spaced--large">
<div class="column is-9">
<div class="page-content--block">
<figure class="page-content--primary-image">
<img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha/krisha-4.jpg" />
</figure>
</div>
</div>
</div>
<div class="columns is-centered is-spaced--large">
<section class="column is-6">
<section class="page-content--block_editor-content js--reframe">
<p>The opening shot of <a href="/cast-and-crew/trey-edward-shults">Trey Edward Shults</a>’ debut feature film “<a href="/reviews/krisha-2016">Krisha</a>” unsettles me. Ominous music is played on the soundtrack for a while without anything shown on the black screen, and then there comes the close-up shot of a woman who clearly looks quite troubled for some reason. While watching her unnerving glare on the screen, I could not help but be reminded again of a similar moment in <a href="/cast-and-crew/stanley-kubrick">Stanley Kubrick</a>’s “<a href="/reviews/great-movie-the-shining-1980">The Shining</a>” (1980). Remember that brief but very disturbing scene where the camera slowly focuses on the frighteningly intense glare from <a href="/cast-and-crew/jack-nicholson">Jack Nicholson</a>’s character? </p>
</section>
</section>
</div>
<div class="columns is-centered is-spaced--large">
<section class="column is-12">
<section class="page-content--block">
<section class="page-content--ad-block column is-12 is-paddingless">
<div class="advertisement">
<span class="advertisement--title">Advertisement</span>
<div class="advertisement--container">
<div class="AdvallyTag" data-autosize="superleaderboard" data-jigsaw="true" data-slot="/29848019/ROS_LEADERBOARD_1" id="ROS_LEADERBOARD-1"></div>
</div>
</div>
</section>

</section>
</section>
</div>
<div class="columns is-centered is-spaced--large">
<section class="column is-6">
<section class="page-content--block_editor-content js--reframe">
 <p>“Krisha” is actually not a horror flick but a small intimate family drama. And yet it does feel like a horror movie from time to time as it closely observes what may be another bad day in the problematic life of its title character. The more we get to know her, the more it is apparent that she is a walking mess of troubles, and we cannot help but brace ourselves for tragedy.</p> <p>At first, Krisha (<a href="/cast-and-crew/krisha-fairchild">Krisha Fairchild</a>) believes that she can control herself well enough for the upcoming family dinner on Thanksgiving Day, and everything seems to be fine as she arrives at a big suburban house where her sister Robyn (<a href="/cast-and-crew/robyn-fairchild">Robyn Fairchild</a>) lives with her family. Other family members are already there, and they all cordially greet Krisha along with Robyn, but it slowly becomes apparent to us that Krisha has been a black sheep in the family for many years. We gather that she has struggled with a serious addiction problem, and we can easily guess that she was not a very good mother to her son in the past because of that. Although Trey, played by Shults himself, has been quite close to Robyn and her husband since Krisha abandoned him a long time ago, Krisha really wants to reconnect with her son during this family meeting, and that is the main reason why she is determined to hold herself together as much as possible.</p> <figure><img src="https://s3.amazonaws.com/static.rogerebert.com/redactor_assets/pictures/62533fd7b8b50d26cf4a1b6f/content_krisha2.jpg" data-image="[object Object]"></figure> <p>However, her current condition is not so ideal to say the least. Krisha manages to look sober and well to Robyn and other family members, but she constantly feels agitated just like many alcoholics struggling with their urge to drink. Her private metal box is full of medicine pills which are probably for calming her nerves, and then we notice the missing tip of her right index finger covered in a bandage. (A small bit of trivia: this notable detail was incorporated into the film right before its shooting due to the lead actress’ unexpected injury). When she later tries to call some guy who is probably her boyfriend, it looks like she recently hit another bottom and made a big mess as a consequence. We can only imagine how her private life has been strewn with many unresolved issues.  </p> <p>As many of her family members are busy with preparing for the dinner or watching a football game on TV, Krisha gladly participates in preparing a big turkey to be served. She feels a bit better being around her family members again, but she is still on the edge while constantly aware of the noisy domestic environment surrounding her. Around the point when the turkey is finally prepared for the oven, she gets a private moment with her son, but then she overlooks how they have been estranged from each other for years. She tries to tell him how much she wants to be close to him again; her son only gives casual replies to her without looking at her at all. This certainly puts another strain on her unstable mind, which is more like a ticking bomb as dinner approaches.</p>
</section>
</section>
</div>
<div class="columns is-centered is-spaced--large">
<section class="column is-12">
<section class="page-content--block">
<section class="page-content--ad-block column is-12 is-paddingless">
<div class="advertisement">
<span class="advertisement--title">Advertisement</span>
<div class="advertisement--container">
<div class="AdvallyTag" data-autosize="superleadermpu" data-jigsaw="true" data-multiple="true" data-slot="/29848019/ROS_INCONTENT" id="ROS_INCONTENT-banner1"></div>
</div>
</div>
</section>

</section>
</section>
</div>
<div class="columns is-centered is-spaced--large">
<section class="column is-6">
<section class="page-content--block_editor-content js--reframe">
 <p>To reflect his protagonist’s increasingly unhinged state of mind, Shults, who also edited the film, tries some notable stylish touches. Via its edgy sound design and editing, the movie frequently throws us into disorienting moments, and the resulting sense of confusion and nervousness on the screen is further accentuated by <a href="/cast-and-crew/brian-mcomber">Brian McOmber</a>’s cacophonous score. Besides making the movie feel as jumpy as its heroine, it helps us empathize more with the emotional tension around her and the other characters in the film, who mostly look jolly and cheerful on the surface but maintain some distance from her nonetheless. </p> <p>As his camera unobtrusively stays or moves around Krisha and the other characters in the film like another guest in the house, cinematographer <a href="/cast-and-crew/drew-daniels">Drew Daniels</a>, who subsequently collaborated more with Shults in “<a href="/reviews/it-comes-at-night-2017">It Comes at Night</a>” (2017) and “<a href="/reviews/waves-movie-review-2019">Waves</a>” (2019), gives us a series of impressive visual moments including the long-take opening scene. I appreciate how he and Shults skillfully utilize three different screen ratios for dramatic effect throughout the film, and I am impressed again by how the movie effortlessly shifts itself among these three different screen ratios without distracting us at all. </p> <figure><img src="https://s3.amazonaws.com/static.rogerebert.com/redactor_assets/pictures/62533fdfb8b50d52124a1bd7/content_Krisha3.jpg" data-image="[object Object]"></figure> <p>The movie, which was developed from Shults’ 2014 short film of the same name, never looks rough or cheap although its production budget was no more than $30,000, and it was shot over only nine days at the house belonging to Shults’ mother. Mainly consisting of non-professional performers who are Shults’ family members and close friends, the cast look uniformly believable as family characters with a long history among them, even when we cannot grasp well how they are exactly related to each other. As a matter of fact, Krisha Fairchild is Shults’ aunt while Robyn Fairchild is his mother, and Trey’s grandmother in the film is played by Shults’ own grandmother.   </p>
</section>
</section>
</div>
<div class="columns is-centered is-spaced--large">
<section class="column is-12">
<section class="page-content--block">
<section class="page-content--ad-block column is-12 is-paddingless">
<div class="advertisement">
<span class="advertisement--title">Advertisement</span>
<div class="advertisement--container">
<div class="AdvallyTag" data-autosize="superleadermpu" data-jigsaw="true" data-multiple="true" data-slot="/29848019/ROS_INCONTENT" id="ROS_INCONTENT-banner2"></div>
</div>
</div>
</section>

</section>
</section>
</div>
<div class="columns is-centered is-spaced--small">
<section class="column is-6">
<section class="page-content--block_editor-content js--reframe">
 <p>Full of raw spontaneity and emotional intensity reminiscent of <a href="/cast-and-crew/gena-rowlands">Gena Rowlands</a> in <a href="/cast-and-crew/john-cassavetes">John Cassavetes</a>’ “<a href="/reviews/great-movie-a-woman-under-the-influence-1974">A Woman Under the Influence</a>” (1974), Krisha Fairchild, who is a veteran performer in contrast to many other cast members in the film, is utterly captivating in her fearless performance. Her character, who is partially based on a member of Shults’ family, is frequently unlikable and pathetic to say the least, but she also comes to us as a flawed and complex character worthwhile to observe. Thanks to Fairchild’s nuanced acting, we come to understand Krisha’s desperate needs.</p> <p>Robyn Fairchild holds her own as Krisha’s caring sister, and she is especially effective when her character has a small but painful private conversation with Krisha later in the story. As one of a few professional performers in the film, <a href="/cast-and-crew/bill-wise">Bill Wise</a> gives a colorful supporting performance as a sardonic family member who does not like Krisha that much, and his best moment in the film comes from when his character indirectly but acerbically points out Krisha’s private issues in the middle of their supposedly casual chat.</p> <p>Overall, “Krisha” is a small but powerful piece of work which deserves to be mentioned along with Shults’ two equally commendable subsequent films, and it is a shame that the movie has been rather overlooked despite receiving a considerable amount of praises from many critics when it came out several years ago. (Shameless full disclosure: I gladly included it in my annual list, and I have never regretted that). This is certainly not a comfortable film, but it is one of most harrowing dramas about addiction and family issues I have ever seen. "Krisha" will give you a deeper understanding as to how addicts cannot help but cause trouble for not only themselves but those they love.</p>
</section>
</section>
</div>
<div class="columns is-centered is-spaced--large">
<section class="column is-12">
<section class="page-content--block">
<section class="page-content--ad-block column is-12 is-paddingless">
<div class="advertisement">
<span class="advertisement--title">Advertisement</span>
<div class="advertisement--container">
<div class="AdvallyTag" data-autosize="superleadermpu" data-jigsaw="true" data-multiple="true" data-slot="/29848019/ROS_INCONTENT" id="ROS_INCONTENT-banner3"></div>
</div>
</div>
</section>

</section>
</section>
</div>

<div class="columns is-centered is-spaced--large">
<section class="column is-6">
<div class="contributor-bio">
<figure class="columns is-mobile">
<div class="column is-paddingless">
<a class="contributor-bio--image" href="/contributors/seongyong-cho"><figure class="image">
<img alt="Seongyong Cho" title="Seongyong Cho" src="/assets/missing/missing-user-featured-1c2ef2b1f083f6c8fab543cbff98a56e722534ba072456472879c1f7342e97b7.png" />
</figure>
</a></div>
<div class="caption">
<figcaption class="contributor-bio--text">
<a href="/contributors/seongyong-cho"><h5 class="contributor-bio--name">Seongyong Cho</h5>
</a><p>Seongyong Cho writes extensively about film on his site, <a href="http://kaist455.wordpress.com/">Seongyong's Private Place</a>.<br></p>
</figcaption>
</div>
</figure>
</div>

</section>
</div>
<div class="columns is-centered is-mobile is-spaced--large">
<section class="column is-12">
<section class="page-content--block">
<div class="page-content--section-title">
<span class="page-content--section-title--overline"></span>
<h3 class="page-content--section-title--title">Latest blog posts</h3>
</div>
<div class="columns is-centered is-mobile is-multiline">
<div class="column is-3-tablet is-half-mobile">
<article class="blog-stack">
<div class="blog-stack--image">
<a href="/chazs-blog/rogers-top-ten-lists-1973"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/chazs-blog/rogers-top-ten-lists-1973/thumb_Top10_1973.jpg" />
</a></div>
<h4 class="blog-stack--header">
<a href="/chazs-blog/rogers-top-ten-lists-1973">Roger's Top Ten Lists: Best Films of 1973</a>
</h4>
<div class="blog-stack--timestamp">
about 3 hours
ago
</div>
</article>
</div>
<div class="column is-3-tablet is-half-mobile">
<article class="blog-stack">
<div class="blog-stack--image">
<a href="/chazs-blog/our-favorite-roger-reviews-the-joy-luck-club"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/chazs-blog/our-favorite-roger-reviews-the-joy-luck-club/thumb_joy-luck-club-slide-1.jpg" />
</a></div>
<h4 class="blog-stack--header">
<a href="/chazs-blog/our-favorite-roger-reviews-the-joy-luck-club">Our Favorite Roger Reviews: The Joy Luck Club</a>
</h4>
<div class="blog-stack--timestamp">
about 3 hours
ago
</div>
</article>
</div>
<div class="column is-3-tablet is-half-mobile">
<article class="blog-stack">
<div class="blog-stack--image">
<a href="/streaming/roar-is-a-star-studded-girlboss-anthology-that-occasionally-whimpers"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/streaming/roar-is-a-star-studded-girlboss-anthology-that-occasionally-whimpers/thumb_Roar_Photo_010201.jpg" />
</a></div>
<h4 class="blog-stack--header">
<a href="/streaming/roar-is-a-star-studded-girlboss-anthology-that-occasionally-whimpers">Roar Is a Star-Studded Girlboss Anthology That Occasionally Whimpers</a>
</h4>
<div class="blog-stack--timestamp">
about 5 hours
ago
</div>
</article>
</div>
<div class="column is-3-tablet is-half-mobile">
<article class="blog-stack">
<div class="blog-stack--image">
<a href="/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/blog_post/primary_image/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha/thumb_krisha-4.jpg" />
</a></div>
<h4 class="blog-stack--header">
<a href="/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha">It Feels Like a Horror Movie: On Trey Edward Shults' Krisha</a>
</h4>
<div class="blog-stack--timestamp">
about 5 hours
ago
</div>
</article>
</div>
</div>
</section>
</section>
</div>

<div class="columns is-centered is-mobile is-spaced--large">
<section class="column is-12">
<section class="page-content--block">
<div class="page-content--section-title">
<span class="page-content--section-title--overline"></span>
<h3 class="page-content--section-title--title">Latest reviews</h3>
</div>
<div class="columns is-centered is-mobile is-multiline">
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/the-northman-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/the-northman-2022/widget_northman_ver3.jpg" />
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/the-northman-movie-review-2022">The Northman</a>
</h5>
<h6 class="review-stack--byline">
Robert Daniels
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i></span>
</div>
</div>
</div>
</div>
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/ambulance-movie-review-2022"><img src="/assets/missing/missing-poster-widget-34e9acb353fa45861e88ab05af0f39d009dd223160b2c25aae493ecde78dae16.png" />
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/ambulance-movie-review-2022">Ambulance</a>
</h5>
<h6 class="review-stack--byline">
Katie Rife
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i></span>
</div>
</div>
</div>
</div>
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/cow-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/cow-2022/widget_cow-poster.jpeg" />
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/cow-movie-review-2022">Cow</a>
</h5>
<h6 class="review-stack--byline">
Tomris Laffly
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i><i title="star-half" class="icon-star-half"></i></span>
</div>
</div>
</div>
</div>
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/the-girl-and-the-spider-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/the-girl-and-the-spider-2022/widget_the-girl-and-the-spider-poster-2022.jpeg" />
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/the-girl-and-the-spider-movie-review-2022">The Girl and the Spider</a>
</h5>
<h6 class="review-stack--byline">
Glenn Kenny
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i></span>
</div>
</div>
</div>
</div>
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/aline-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/aline-2022/widget_aline-movie-poster-2022.jpeg" />
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/aline-movie-review-2022">Aline</a>
</h5>
<h6 class="review-stack--byline">
Sheila O&#39;Malley
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i></span>
</div>
</div>
</div>
</div>
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/donbass-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/donbass-2022/widget_donbass-poster.jpeg" />
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/donbass-movie-review-2022">Donbass</a>
</h5>
<h6 class="review-stack--byline">
Simon Abrams
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i></span>
</div>
</div>
</div>
</div>

</div>
</section>
</section>
</div>

<div class="columns is-centered is-spaced--large">
<section class="column is-12">
<div class="advertisement">
<span class="advertisement--title">Advertisement</span>
<div id="adContentRecommendation"></div>
</div>

</section>
</div>
<div class="columns is-spaced--large">
<div class="column">
<section class="page-content--block">
<div class="page-content--section-title">
<span class="page-content--section-title--overline"></span>
<h3 class="page-content--section-title--title">Comments</h3>
<div class="columns is-centered">
<div class="column is-8">
<div id="disqus_thread"></div>
<script type="text/javascript">
    /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
    var disqus_shortname = 'rogerebert';
    var disqus_title = "It Feels Like a Horror Movie: On Trey Edward Shults\' Krisha | Far Flungers | Roger Ebert";
    var disqus_identifier = "/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha";
    var disqus_url = "https://www.rogerebert.com/far-flung-correspondents/it-feels-like-a-horror-movie-on-trey-edward-shults-krisha";


    /* * * DON'T EDIT BELOW THIS LINE * * */
    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = 'https://' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<a href="http://disqus.com" class="dsq-brlink" rel="nofollow">comments powered by <span class="logo-disqus">Disqus</span></a>

</div>
<div class="column is-4">
<section class="page-content--ad-block column is-12 is-paddingless">
<div class="advertisement">
<span class="advertisement--title">Advertisement</span>
<div class="advertisement--container">
<div class="AdvallyTag" data-autosize="mpu" data-slot="/29848019/div-gpt-ad-MR1" id="div-gpt-ad-MR1"></div>
</div>
</div>
</section>

<div class="js--sticky">
<section class="page-content--ad-block column is-12 is-paddingless">
<div class="advertisement">
<span class="advertisement--title">Advertisement</span>
<div class="advertisement--container">
<div class="AdvallyTag" data-autosize="mpu" data-slot="/29848019/div-gpt-ad-MR2" id="div-gpt-ad-MR2"></div>
</div>
</div>
</section>

</div>
</div>
</div>
</div>
</section>
</div>
</div>


</div>
<footer class="south nocontent container">
<div class="columns is-centered is-mobile is-spaced--large">
<section class="column is-12">
<section class="page-content--block">
<div class="page-content--section-title">
<span class="page-content--section-title--overline"></span>
<h3 class="page-content--section-title--title">Popular reviews</h3>
</div>
<div class="columns is-centered is-mobile is-multiline">
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/cow-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/cow-2022/widget_cow-poster.jpeg" />
<div class="review-stack--overlay">
<span class="review-stack--thumb _up"></span>
</div>
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/cow-movie-review-2022">Cow</a>
</h5>
<h6 class="review-stack--byline">
Tomris Laffly
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i><i title="star-half" class="icon-star-half"></i></span>
</div>
</div>
</div>
</div>
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/babi-yar-context-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/babi-yar-context-2022/widget_babi-yar-context-poster.jpg" />
<div class="review-stack--overlay">
<span class="review-stack--thumb _up"></span>
</div>
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/babi-yar-context-movie-review-2022">Babi Yar. Context</a>
</h5>
<h6 class="review-stack--byline">
Simon Abrams
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i><i title="star-half" class="icon-star-half"></i></span>
</div>
</div>
</div>
</div>
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/sonic-the-hedgehog-2-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/sonic-the-hedgehog-2-2022/widget_sonic-poster.jpeg" />
<div class="review-stack--overlay">
<span class="review-stack--thumb _down"></span>
</div>
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/sonic-the-hedgehog-2-movie-review-2022">Sonic the Hedgehog 2</a>
</h5>
<h6 class="review-stack--byline">
Nell Minow 
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i></span>
</div>
</div>
</div>
</div>
<div class="column is-2-tablet is-half-mobile">
<div class="review-stack">
<a class="review-stack--poster image is-3by4" href="/reviews/morbius-movie-review-2022"><img src="https://s3.amazonaws.com/static.rogerebert.com/uploads/movie/movie_poster/morbius-2022/widget_morbius-poster-2022.jpeg" />
<div class="review-stack--overlay">
<span class="review-stack--thumb _down"></span>
</div>
</a><div class="review-stack--info">
<div class="review-stack--header">
<h5 class="review-stack--title">
<a href="/reviews/morbius-movie-review-2022">Morbius</a>
</h5>
<h6 class="review-stack--byline">
Katie Rife
</h6>
</div>
<div class="review-stack--rating">
<span class="star-rating _small"><i title="star-full" class="icon-star-full"></i><i title="star-full" class="icon-star-full"></i></span>
</div>
</div>
</div>
</div>

</div>
</section>
</section>
</div>

<div class="container is-fullhd">
<div class="columns is-centered is-spaced--medium">
<section class="column is-12">
<section class="page-content--block">
<section class="mailing-list">
<div class="mailing-list--image">
<img alt="Ebert Thumbs Up" src="/assets/v2/ebert-thumb-a5ab7247762a64276f661a297845728fe95378b486e41852925efc73accc4aa9.svg" />
</div>
<div class="mailing-list--inner">
<h4 class="mailing-list--title">The best movie reviews, in your inbox</h4>
<form action="https://rogerebert.us6.list-manage.com/subscribe/post?u=53d28014f6494e01798442219&amp;amp;id=9ac9effdc7" class="mailing-list--form validate js--newsletter" id="mc-embedded-subscribe-form" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div class="mailing-list--input">
<input class="input required email" id="mce-EMAIL" name="EMAIL" placeholder="Enter your email" type="email" value="">
</div>
<div id="mce-responses">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div>
<div class="mailing-list--button">
<input class="button" id="mc-embedded-subscribe" name="subscribe" type="submit" value="Subscribe">
</div>
</form>
</div>
</section>
</section>
</section>
</div>

<nav class="columns is-mobile is-multiline">
<div class="column is-3-desktop is-half-mobile">
<h4>Movie reviews</h4>
<p class="link"><a href="/great-movies">Roger&#39;s Greatest Movies</a></p>
<p class="link"><a href="/reviews">All Reviews</a></p>
<p class="link"><a title="Cast and crew" href="/cast-and-crew">Cast and crew</a></p>
<div class="south--prime">
<h4>Ebert Prime</h4>
<p class="link"><a title="Sign up for Ebert Prime" href="/prime">Sign Up</a></p>
</div>
</div>
<div class="column is-3-desktop is-half-mobile">
<h4>Movie genres</h4>
<p class="link"><a href="/collections/action-movies">Action</a></p>
<p class="link"><a href="/collections/amazon-prime-movies">Amazon Prime</a></p>
<p class="link"><a href="/collections/comedy-movies">Comedy</a></p>
<p class="link"><a href="/collections/documentary-movies">Documentary</a></p>
<p class="link"><a href="/collections/drama-movies">Drama</a></p>
<p class="link"><a href="/collections/horror-movies">Horror</a></p>
<p class="link"><a href="/collections/mystery-movies">Mystery</a></p>
<p class="link"><a href="/collections/netflix-movies">Netflix</a></p>
<p class="link"><a href="/collections/romance-movies">Romance</a></p>
<p class="link"><a href="/collections/science-fiction-movies">Science Fiction</a></p>
<p class="link"><a href="/collections/suspense-movies">Suspense</a></p>
<p class="link"><a href="/collections/thriller-movies">Thriller</a></p>
</div>
<div class="column is-3-desktop is-half-mobile">
<h4>Blogs</h4>
<p class="link"><a href="/reviews">Reviews</a></p>
<p class="link"><a href="/chazs-blog">Chaz&#39;s Journal</a></p>
<p class="link"><a href="/mzs">MZS</a></p>
<p class="link"><a href="/great-movies">Great Movies</a></p>
<p class="link"><a href="/far-flung-correspondents">Far Flungers</a></p>
<p class="link"><a href="/interviews">Interviews</a></p>
<p class="link"><a href="/video-games">Video Games</a></p>
<p class="link"><a href="/black-writers-week">Black Writers Week</a></p>
<p class="link"><a href="/features">Features</a></p>
<p class="link"><a href="/streaming">TV/Streaming</a></p>
<p class="link"><a href="/roger-ebert">Roger Ebert</a></p>
<p class="link"><a href="/festivals">Festivals &amp; Awards</a></p>
</div>
<div class="column is-3-desktop is-half-mobile">
<h4>Ebert Co.</h4>
<p class="link"><a title="About the site" href="/about">About the site</a></p>
<p class="link"><a title="Contact us" href="/contact-us">Contact us</a></p>
<p class="link"><a href="mailto:advertising@ebertdigital.com">Advertise with Us</a></p>
<p class="link"><a title="Contributors" href="/contributors">Contributors</a></p>
<div class="social-media--icons">
<a title="Like us on Facebook" rel="nofollow" class="facebook" href="https://www.facebook.com/RogerEbert">Like us on Facebook</a>
<a title="Follow us on Twitter" rel="nofollow" class="twitter" href="https://twitter.com/ebertchicago">Follow us on Twitter</a>
<a title="Watch our YouTube channel" rel="nofollow" class="youtube" href="https://www.youtube.com/channel/UCnqyHrjt_9rffNXPaNO7RhQ">Watch our YouTube channel</a>
</div>
<div class="columns is-multiline south--memoriam">
<div class="column is-full">
<h4>"Roger Ebert loved movies."</h4>
<p class="link"><a title="In Memoriam 1942-2013" href="/memoriam">In Memoriam 1942-2013</a></p>
</div>
<div class="column south--memoriam-image">
<a title="In Memoriam 1942-2013" href="/memoriam"><img alt="Roger Ebert giving Thumbs up" src="/assets/v2/roger-f7d187c3e0336205f50f366bdce798210b160173facf59555f66c0b5dfa284e2.png" />
</a></div>
</div>
</div>
</nav>
</div>
<div class="footer--background">
<div class="container is-fullhd">
<div class="footer--bottom">
<p class="footer--copyright">
<a title="Ebert Digital LLC" href="http://www.ebertdigital.com/">Ebert Digital LLC</a>
</p>
<p class="footer--link-with-pipe">&copy; Copyright 2022</p>
|
<p class="footer--link-with-pipe"><a title="Privacy policy" href="/privacy-policy">Privacy policy</a></p>
|
<p class="footer--link-with-pipe"><a title="Terms of use" href="/terms-of-use">Terms of use</a></p>
</div>
</div>
</div>
</footer>

<!-- BEGIN Google Custom Search Tag -->
<script>
  (function() {
    var cx = '004943367334924041372:turuh-9ckxm';
    var gcse = document.createElement('script'); gcse.type = 'text/javascript'; gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(gcse, s);
  })();
</script>
<!-- END Google Custom Search Tag -->
<script src="/packs/js/application-8593261c40e04cb49b06.js"></script>

<script type="text/javascript">
/* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
var disqus_shortname = 'rogerebert';

/* * * DON'T EDIT BELOW THIS LINE * * */
(function () {
var s = document.createElement('script'); s.async = true;
s.type = 'text/javascript';
s.src = 'https://' + disqus_shortname + '.disqus.com/count.js';
(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
}());
</script>

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p--5eK9YWya67RJ"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p--5eK9YWya67RJ.gif" border="0"
height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->
<script>
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-20813715-2']);
  _gaq.push (['_gat._anonymizeIp']);
  _gaq.push(['_trackPageview']);
  
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

<script type="text/javascript">
setTimeout(function () {
  var a = document.createElement("script");
  var b = document.getElementsByTagName("script")[0];
  a.src = document.location.protocol +
          "//dnn506yrbagrg.cloudfront.net/pages/scripts/0013/1161.js?" +
          Math.floor(new Date().getTime() / 3600000);
  a.async = true;
  a.type = "text/javascript";
  b.parentNode.insertBefore(a,b);
}, 1);
</script>

</body>
</html>
